God loves me, still

How the engine works

Moderators: Greenleaf, KTA, BC847, Richie O

God loves me, still

Postby mhuppertz » Thu Jan 11, 2007 8:37 pm

So, I have been living with a frosty cab because it's better than blocking off the radiator and loosing the benefit of the intercooler, but yesterday, bling! I had heat. The temp needle moved up to it's normal position! I have had good cab heat since then.... I guess the thermostat was never closing all the way THE WHOLE TIME I HAVE OWNED THE TRUCK! It always worked fine when it was warmer, and when I would block it off the temp would eventually come up to normal after it got a little warmer. I just assumed it was a diesel thing. I actually had to turn the heat DOWN this morning!!!
MARK
'93 W250, HTT Stage IV/16cm, POD's, cut AFC pin, Pump advanced, Pyro, Boost, Fuel Pressure Gauges all non functional, burned wiring, 3/8” fuel line, BHAF on custom intake, 3,200 Spring, ARP Studs, New Head at 392K, Detroit Locker, NV4500, other stuff…
User avatar
mhuppertz
14mm rotor
 
Posts: 578
Joined: Sat Jan 06, 2007 9:44 am
Location: Tijeras (Zuzax) NM

Postby 92 D/UNIT » Thu Jan 11, 2007 9:40 pm

so did you put a new thermostat in?
Brian 92 D 250 250K, A518, pump mods, BHAF, 4X15s, 4" turbo back dual exh, 3200 spring, HTB2 62/12.

SOLD 92 w250 ex cab, 5 spd, 3.54, 320,000, WH1E 14, Fuel pin, pods,shortened 4200 gs, Bhaf, 4" turbo back
388/886
User avatar
92 D/UNIT
fuel screw!!!!
 
Posts: 262
Joined: Mon Jan 01, 2007 11:41 pm
Location: NAMPA IDAHO

Postby mhuppertz » Fri Jan 12, 2007 6:12 am

No, the old one just started closing all the way. I will put a new one in though eventually..
MARK
'93 W250, HTT Stage IV/16cm, POD's, cut AFC pin, Pump advanced, Pyro, Boost, Fuel Pressure Gauges all non functional, burned wiring, 3/8” fuel line, BHAF on custom intake, 3,200 Spring, ARP Studs, New Head at 392K, Detroit Locker, NV4500, other stuff…
User avatar
mhuppertz
14mm rotor
 
Posts: 578
Joined: Sat Jan 06, 2007 9:44 am
Location: Tijeras (Zuzax) NM
Top

Postby PToombs » Sat Jan 13, 2007 3:35 pm

I can't believe you need heat in NM! What did it do, drop to 70*? :o
pete

Just enough power to break everything behind the crankshaft.
User avatar
PToombs
14mm rotor
 
Posts: 11281
Joined: Sun Jan 07, 2007 6:13 pm
Location: Syracuse NY. Snow central!
Top

Postby mhuppertz » Sat Jan 13, 2007 6:10 pm

PToombs wrote:I can't believe you need heat in NM! What did it do, drop to 70*? :o


I'm at 7,000 ft elevation, and we recently had 3' of snow on the ground. It's been well below zero many times already. We haven't seen 70* in a long time!
MARK
'93 W250, HTT Stage IV/16cm, POD's, cut AFC pin, Pump advanced, Pyro, Boost, Fuel Pressure Gauges all non functional, burned wiring, 3/8” fuel line, BHAF on custom intake, 3,200 Spring, ARP Studs, New Head at 392K, Detroit Locker, NV4500, other stuff…
User avatar
mhuppertz
14mm rotor
 
Posts: 578
Joined: Sat Jan 06, 2007 9:44 am
Location: Tijeras (Zuzax) NM
Top


Return to Engine

Who is online

Users browsing this forum: No registered users and 1 guest