Feels like I have no turbo

How the engine works

Moderators: Greenleaf, KTA, BC847, Richie O

Feels like I have no turbo

Postby 92cummins89 » Sat Jul 08, 2017 7:56 pm

I swapped in an he 351cw

I hooked up a 16' lowboy An my Yamaha rhino 700 it just doesn't seem to have any power I lose speed going up hills any ideas
1992 4x4, 4” diamond eye exhaust, nv4500, he351cw
92cummins89
fuel screw!!!!
 
Posts: 179
Joined: Sat Sep 14, 2013 8:46 pm

Re: Feels like I have no turbo

Postby laneends » Sun Jul 09, 2017 2:14 am

We are going to need a bit more info... do you have gauges? If so, what do they say? Does the trailer have brakes? If so, are they dragging?
1990 D-250 with getrag 360: pyro, boost, volt, oil pressure, fuel pressure, and water temp gauges, hot screw, 366 gov spring, THD pin, M&H dynamic timing spacer, throttle linkage adjusted for full travel, 4" turbo back exhaust, THD's LPPLP, BHAF, south bend clutch. THD 5x13 comps, 362sxe, 3" crossover, pump to the head
User avatar
laneends
fuel screw!!!!
 
Posts: 53
Joined: Sat Sep 26, 2015 1:50 am
Location: Kent washington/Bearing Sea

Re: Feels like I have no turbo

Postby 92cummins89 » Sun Jul 09, 2017 8:06 am

No boost gauges an there are no electric hook ups in the rear for a trailer
1992 4x4, 4” diamond eye exhaust, nv4500, he351cw
92cummins89
fuel screw!!!!
 
Posts: 179
Joined: Sat Sep 14, 2013 8:46 pm
Top

Re: Feels like I have no turbo

Postby Gots_a_sol » Sun Jul 09, 2017 9:31 am

What did you do with the wastegate?
-Joe

00 Excursion - 12v/nv4500, he351cw, 5x12s, 366 spring, THD piston pump, 4" intake/exhaust
Gots_a_sol
fuel screw!!!!
 
Posts: 390
Joined: Fri May 28, 2010 11:45 pm
Location: Charles Town, WV
Top

Re: Feels like I have no turbo

Postby 92cummins89 » Sun Jul 09, 2017 11:15 am

Spring gated it
1992 4x4, 4” diamond eye exhaust, nv4500, he351cw
92cummins89
fuel screw!!!!
 
Posts: 179
Joined: Sat Sep 14, 2013 8:46 pm
Top

Re: Feels like I have no turbo

Postby Remps » Sun Jul 09, 2017 11:33 am

Boost making it to the afc?
'90 D250 R/C,727,IC,6x.009's,1/8" bump,fuel psi,straight pipe w/5" stack.
'90 W250 R/C,47rh,K@N,HX35,1/8" bump,2nd gen IC,boost,egt,trans temp.3.07's.
'96 2500 S/C L/B,2wd,NV5600,3.54 L/S,cai,egt,pacbrake,mbrp exhaust,10 plate.
Bring back the Bank of Canada, PRE- 1974.
User avatar
Remps
14mm rotor
 
Posts: 1099
Joined: Sun May 03, 2009 12:57 am
Location: Saskatchewan
Top

Re: Feels like I have no turbo

Postby oldestof11 » Sun Jul 09, 2017 12:54 pm

Gonna need a boost gauge...
Jon
93 D250~ Mismatch of cheap parts, trying to look fast going slow
User avatar
oldestof11
14mm rotor
 
Posts: 4147
Joined: Tue Apr 24, 2007 4:46 pm
Location: Northern Illinois
Top

Re: Feels like I have no turbo

Postby 92cummins89 » Sun Jul 09, 2017 3:17 pm

Not sure if it is just doesn't seem to have any power


Is there a way to check it ?

I guess I need to invest in a boost gauge
1992 4x4, 4” diamond eye exhaust, nv4500, he351cw
92cummins89
fuel screw!!!!
 
Posts: 179
Joined: Sat Sep 14, 2013 8:46 pm
Top

Re: Feels like I have no turbo

Postby laneends » Wed May 30, 2018 12:41 am

Curious if you ever got to the bottom of this problem?
1990 D-250 with getrag 360: pyro, boost, volt, oil pressure, fuel pressure, and water temp gauges, hot screw, 366 gov spring, THD pin, M&H dynamic timing spacer, throttle linkage adjusted for full travel, 4" turbo back exhaust, THD's LPPLP, BHAF, south bend clutch. THD 5x13 comps, 362sxe, 3" crossover, pump to the head
User avatar
laneends
fuel screw!!!!
 
Posts: 53
Joined: Sat Sep 26, 2015 1:50 am
Location: Kent washington/Bearing Sea
Top

Re: Feels like I have no turbo

Postby 92cummins89 » Mon Jun 25, 2018 6:59 pm

Well I finally but a boost Gauge in An only pull like 6 lbs of boost any ideas
1992 4x4, 4” diamond eye exhaust, nv4500, he351cw
92cummins89
fuel screw!!!!
 
Posts: 179
Joined: Sat Sep 14, 2013 8:46 pm
Top

Re: Feels like I have no turbo

Postby fatty » Mon Jun 25, 2018 10:54 pm

Wire the wastegate shut and go for a drive. Report back with boost and egt numbers.
91.5 w250
fatty
14mm rotor
 
Posts: 771
Joined: Tue Nov 04, 2008 8:52 pm
Location: Washington
Top

Re: Feels like I have no turbo

Postby PToombs » Tue Jun 26, 2018 5:49 pm

Either you aren't getting any fuel or the IC is leaking like a SOB. Does the truck smoke with the trailer? Did you install a pyro? (EGT gauge)
pete

Just enough power to break everything behind the crankshaft.
User avatar
PToombs
14mm rotor
 
Posts: 11229
Joined: Sun Jan 07, 2007 6:13 pm
Location: Syracuse NY. Snow central!
Top

Re: Feels like I have no turbo

Postby 92cummins89 » Tue Jun 26, 2018 7:31 pm

Don’t have a pyro installed but my boost hasn’t changed any
1992 4x4, 4” diamond eye exhaust, nv4500, he351cw
92cummins89
fuel screw!!!!
 
Posts: 179
Joined: Sat Sep 14, 2013 8:46 pm
Top

Re: Feels like I have no turbo

Postby 92cummins89 » Tue Jun 26, 2018 7:33 pm

It doesn’t smoke to bad not like when I blew a ic boot on my duramax

It smokes but clears up when when I get moving
1992 4x4, 4” diamond eye exhaust, nv4500, he351cw
92cummins89
fuel screw!!!!
 
Posts: 179
Joined: Sat Sep 14, 2013 8:46 pm
Top

Re: Feels like I have no turbo

Postby PToombs » Wed Jun 27, 2018 4:45 pm

The slide pin in the pump top may be stuck also, not giving enough fuel to build boost. It's either that or a boost leak, bad IC, leak in the hose to the AFC, bad IC hose. You are either losing it or not making it.
pete

Just enough power to break everything behind the crankshaft.
User avatar
PToombs
14mm rotor
 
Posts: 11229
Joined: Sun Jan 07, 2007 6:13 pm
Location: Syracuse NY. Snow central!
Top

Next

Return to Engine

Who is online

Users browsing this forum: No registered users and 2 guests