1997 Jeep fuel pump

Shame on you guys

Moderators: Greenleaf, BC847, Richie O

1997 Jeep fuel pump

Postby Richie O » Fri Apr 29, 2011 6:22 pm

Hey guys, how fun is it putting in a fuel pump in a 97 cherokee? My wifes Jeep has been skipping some over the last week or so, but only when taking off. I assumed the filter, or pump may be getting weak. Well today something took a dump. She shut it off and it would not run again. I beat on the tank and did hear the pump. Cranked with no dice. I gave it a sniff of ether and it fired until the ether burned off. Towed it home and of coarse it fired and ran. I think the pump is weak, or the strainer may be plugged. It has almost 150k on it so I think I will just put a new pump and strainer on it anyway. At that milage its on borrowed time anyway. There is no filter on the fuel system other then the strainer in the tank. I wonder if the strainer is plugged and with me trailering it home and sloshing the fuel in the tank it free'd some gunk from it. Looks pretty straight forward. 1 pressure, 1 vent, filler neck, electric plug and 2 straps. Any tips or surprises I may run into? How does the pressure line come apart? I see a connect right at the tank, but do I need any special tools to seperate it? :?
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England

Re: 1997 Jeep fuel pump

Postby ellis93 » Fri Apr 29, 2011 6:45 pm

I think you have it figured out. Can't remember about the fuel lines :|
93 D250 ,5 speed,4.11s,k&n autometer tach pyro trans boost guages,GDS 60mm h1c 14cm,honed 5x10,hplp/reg,1/8 timing,M+H M2 fuel pin, tims cooler tubz
User avatar
ellis93
14mm rotor
 
Posts: 7731
Joined: Wed Feb 17, 2010 3:16 pm
Location: lucedale,mississippi

Re: 1997 Jeep fuel pump

Postby Richie O » Sat Apr 30, 2011 5:31 pm

Pretty straight forward. If the strap bolts had not broken it would have gone quicker. Spent most of the day on it between pulling the tank, removing the pump, go get new one, and install. The strainer on the old one had fallen off at some point so who knows how long the pump was pulling crap into it. It runs and drives so we will see. The only problem is it ran again before I started. :evil: I always hate working on stuff when it runs half the time. You never know if you actually fixed it. One strap loosened up and the second one broke, with me under it and a half tank of fuel. I had a jack ready to put under it, but had to loosen it up first. Took me a minute to get out from under it and the jeep. :lol: I fixed the broken strap, then when installing the tank the second one broke while trying to get it tight. 14 years of salt for ya. $ 127.00 bucks later, it has a new pump. :x
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England
Top

Re: 1997 Jeep fuel pump

Postby Richie O » Fri May 06, 2011 5:15 pm

OK, pump did not fix it. Ran good for 3 days. It did the same thing again. Crank, no run. Gave it ether and it took right off and kept running fine. Shut it off, crank, no start. Sniff or ether, nothing. Pull one plug wire and check for spark, fired right up on 5 cyl's. Shut it off, crank, no start, no spark. :evil: I pull the cap and its crusty and rusty. Scrape the crud off the cap contacts, fires right up. Put new cap, rotor, plugs in it and runs fine. Wife leaves and calls 5 minutes later. Its running like poo. I told her to drive it the rest of the way to work. So, anyway, I have a gremlin somewhere that works, then don't. I wish it would just crap out so I could find the issue. :roll: Everything I replaced needed to be done anyway, but now I don't want to throw parts at it to get it to run. I'm not looking forward to sending it to the shop, but I think thats where I am at.
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England
Top

Re: 1997 Jeep fuel pump

Postby ellis93 » Fri May 06, 2011 6:14 pm

Try the crank sensor first Mr RichieO. They're cheap and are pretty bad about things like this. Also check the wiring to it. Sometimes it rubs and can kill the 5volt ref signal that the computer sends to the different sensors.
93 D250 ,5 speed,4.11s,k&n autometer tach pyro trans boost guages,GDS 60mm h1c 14cm,honed 5x10,hplp/reg,1/8 timing,M+H M2 fuel pin, tims cooler tubz
User avatar
ellis93
14mm rotor
 
Posts: 7731
Joined: Wed Feb 17, 2010 3:16 pm
Location: lucedale,mississippi
Top

Re: 1997 Jeep fuel pump

Postby Richie O » Fri May 06, 2011 7:41 pm

I have not even looked. Where is it on the 4.0?
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England
Top

Re: 1997 Jeep fuel pump

Postby ellis93 » Fri May 06, 2011 7:46 pm

Driver side, in the top of trans bell housing. 11 or 12mm socket for the two bolts holding it in.
93 D250 ,5 speed,4.11s,k&n autometer tach pyro trans boost guages,GDS 60mm h1c 14cm,honed 5x10,hplp/reg,1/8 timing,M+H M2 fuel pin, tims cooler tubz
User avatar
ellis93
14mm rotor
 
Posts: 7731
Joined: Wed Feb 17, 2010 3:16 pm
Location: lucedale,mississippi
Top

Re: 1997 Jeep fuel pump

Postby Richie O » Fri May 06, 2011 7:55 pm

I will have a looksy in the AM.
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England
Top

Re: 1997 Jeep fuel pump

Postby ellis93 » Fri May 06, 2011 7:56 pm

93 D250 ,5 speed,4.11s,k&n autometer tach pyro trans boost guages,GDS 60mm h1c 14cm,honed 5x10,hplp/reg,1/8 timing,M+H M2 fuel pin, tims cooler tubz
User avatar
ellis93
14mm rotor
 
Posts: 7731
Joined: Wed Feb 17, 2010 3:16 pm
Location: lucedale,mississippi
Top

Re: 1997 Jeep fuel pump

Postby Richie O » Fri May 06, 2011 7:58 pm

NICE! Thanks. :D
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England
Top

Re: 1997 Jeep fuel pump

Postby ellis93 » Sat May 07, 2011 8:13 pm

Any luck
93 D250 ,5 speed,4.11s,k&n autometer tach pyro trans boost guages,GDS 60mm h1c 14cm,honed 5x10,hplp/reg,1/8 timing,M+H M2 fuel pin, tims cooler tubz
User avatar
ellis93
14mm rotor
 
Posts: 7731
Joined: Wed Feb 17, 2010 3:16 pm
Location: lucedale,mississippi
Top

Re: 1997 Jeep fuel pump

Postby Richie O » Sat May 07, 2011 8:23 pm

Well, the wires look good, and its plugged in tight. I looked around and those are around 80 bucks. :roll: Not sure if I want to keep replacing parts til its fixed. I may bring it down to the shop when it acts up so he can plug it in. I would assume it will throw a code if the sensor is bad. He usually plugs them in for free for me. He even told me to come get his fuel pressure gauge to check the new pump output.
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England
Top

Re: 1997 Jeep fuel pump

Postby ellis93 » Sun May 08, 2011 7:32 am

80 bucks is a pretty big guess. If you can check the fuel pressure then do that because 127 dollars for a fuel pump is really cheap. Makes me think you've bought a Master fuel pump, which is a hit and miss brand. Some work some don't.
What brand is the crank sensor you priced. Seems to me that I've not given over 40 or 50 bucks for one.
93 D250 ,5 speed,4.11s,k&n autometer tach pyro trans boost guages,GDS 60mm h1c 14cm,honed 5x10,hplp/reg,1/8 timing,M+H M2 fuel pin, tims cooler tubz
User avatar
ellis93
14mm rotor
 
Posts: 7731
Joined: Wed Feb 17, 2010 3:16 pm
Location: lucedale,mississippi
Top

Re: 1997 Jeep fuel pump

Postby Richie O » Sun May 08, 2011 7:53 am

The pump is a NAPA brand. Their direct replacement BOSCH pump had incorrect socks on it. I had to get the NAPA stuff because it was correct. The sensor was NAPA. They had 2 different lines within 8 or so bucks of each other. I also checked Autozone and the price was close. I'm pretty sure the pump is good because a couple of the no start times there was no spark. This pump sounds alot better then the stock one. I could hardly hear that one and the rail has much more flow now with the new pump. I just pushed on the valve and squirted some out. It flows much harder then the old. We will see. :roll:
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England
Top

Re: 1997 Jeep fuel pump

Postby Richie O » Thu May 12, 2011 5:49 pm

Well today I stopped by the garage with the Jeep. He came right out the door with his scan tool when he saw me. :D It came up with an emmision code. ( had that for years ) and a crank sensor error. YES!!!! I was happy when he said it was a crank sensor code. Ordered one up from NAPA. Got their best eclin grade for an extra 13 bucks. 85 clams delivered to the house. :evil: Now I just need to change it and it looks like my hands are going to have trouble getting behind the motor. :x
1989 W250 727, 3.07 L/S, S300, P/S Intercooler, Stans exaust, Pump adjustments, 127k miles,297 hp
1993 W250 extended cab, rag, 4.10 l/s, 6x16's, HTT 62/71/14 piston l/p, Isspro EV series tach, fuel pressure, boost, oil pres, water temp, volt, pryo, 132k/ 301 hp
1992 W250 with NV4500, 3.54's, 16cm 60mm GDS H1C, ground stock cone, Isspro tach, pryo, boost, fuel pressure, slow, rusty, dented,180k
User avatar
Richie O
Administrator
 
Posts: 4089
Joined: Sat May 17, 2008 9:01 pm
Location: New England
Top

Next

Return to Non diesel

Who is online

Users browsing this forum: No registered users and 1 guest