93 d150 cold weather trouble

Shame on you guys

Moderators: Greenleaf, BC847, Richie O

93 d150 cold weather trouble

Postby dodgebullit » Fri Nov 01, 2013 2:59 am

My 93 has the magnum engine and nv4500 the truck runs great... When its warm it has 280,000 rounds. So when its warm out it runs perfect but when its cold and the motor is cold it will start and idle fine and up to about 2000 rpm it hits a wall starts missing real bad. For now I just let it warm up. When I get up to highway speeds it will just random miss till the motor gets up to operating temp. Its not a real big deal just kinda wondering what it could be?? Fuel pump, pressure regulator,fuel filter, plugs, wires,cap, rotor, coil are about a year old. I'm thinking its a sensor of some kind. Thanks in advance. I love these magnum engines 3.90 gears and a five speed can get you lost in no time
93 D350 dually box that dumps. Getrag, timing bump, ground pin, pump tweaks, intake
93 D150 with the light duty NV4500 and 360 magnum
86 ramcharger
Real trucks don't have glow plugs!!
User avatar
dodgebullit
fuel screw!!!!
 
Posts: 36
Joined: Fri Aug 23, 2013 5:18 pm
Location: chippewa falls wisconsin

Re: 93 d150 cold weather trouble

Postby JimmieD » Thu Nov 07, 2013 11:48 am

First thing I'd do, considering what you've already done, is run some Fuel Injector Cleaner concentrate through it. Lucas is good, there's others.
1967 Dodge D-100 Town Wagon - CPL 858 4BT, HTT Stage II/H1C 16cm/56cm turbo, '93 CTD I/C, 32K spring, minor fuel tweaks, milled head, NV4500, 1 ton springs, '72 D-200 Frt. axle w/ Air Lift bags, 4.10 Dana 60HD, F/R swaybars, Tom Woods shaft.

'90 W-350 gasser...
JimmieD
fuel screw!!!!
 
Posts: 126
Joined: Sat Jan 06, 2007 12:02 pm
Location: Mid-Cal

Re: 93 d150 cold weather trouble

Postby ellis93 » Thu Nov 07, 2013 12:55 pm

Fuel pump,check the psi. It takes more fuel to run a cold motor than a hot motor.

Only other thing would be the coolant temp sensor for the computer, the comp uses the info from it to deliver the appropriate amount of gas at a certain temp. They can give false readings causing the comp to command rich or lean mixtures.


This is the first time I seen this posting :oops:
93 D250 ,5 speed,4.11s,k&n autometer tach pyro trans boost guages,GDS 60mm h1c 14cm,honed 5x10,hplp/reg,1/8 timing,M+H M2 fuel pin, tims cooler tubz
User avatar
ellis93
14mm rotor
 
Posts: 7724
Joined: Wed Feb 17, 2010 3:16 pm
Location: lucedale,mississippi
Top


Return to Non diesel

Who is online

Users browsing this forum: No registered users and 1 guest