'92 D150 starting problem

Moderator: BC847

'92 D150 starting problem

Postby paulpauliepablo » Fri Oct 28, 2016 2:45 pm

HELP Please
Greetings from Providence, Rhode Island. I'm working on a shoestring here and I'm hoping someone out there can help me out. I'm a guy that likes wrenching and trying to figure out a starting problem. Symptom: truck won't start in the morning, turns over, cranks, no start. Leave the key on for 10 minutes to an hour in the on position, the relays next to the battery on the fender wall start to click when they click the check engine light starts flashing, it slows down check engine light goes off, clicking stops truck will start and run normal. I've had the fuel pump sending unit and filter renewed at a local shop to the tune of $415 but she still does this, and the shop said they can't figure it out. I've renewed the relays also. Now it's cold, it won't start clicking and won't do it's thing...
Any sugestions...

IYNHAGTIYODF*┬ęPRL2016

*If you're not having a good time it's your own damn fault!
paulpauliepablo
smoke screw?
 
Posts: 1
Joined: Fri Oct 28, 2016 11:45 am
Location: Providence, Rhode Island

Re: '92 D150 starting problem

Postby matthewh » Fri Oct 28, 2016 3:38 pm

I'd start by checking the voltage at the FSS (fuel shutoff solenoid) when you first turn on the key. My guess is you have an issue in the electric system that is preventing the ASD relay from being energized when you turn the key. Possibly a bad ignition switch, bad ground, etc.
'93 W350 5spd Getrag, 4.10 gears, 83k miles and counting, Mods: LPPP AKA Ma Dually
'54 Dodge M37 6.2/700R4/205, 5.89 gears, WC rear axle
matthewh
14mm rotor
 
Posts: 619
Joined: Mon Feb 18, 2013 3:07 am
Location: Boyne City Michigan

Re: '92 D150 starting problem

Postby dazedandconfused » Fri Oct 28, 2016 4:42 pm

Well since its a D150 I'm assuming it's a gas truck.
Big Andy
1983 Dodge D150 that has been repowered with a 93 Cummins/518 running gear AKA The Ugly Duck! I would much rather build them then buy them.
Click this link to learn how to post pictures. http://1stgen.org/viewtopic.php?f=23&t=13518
User avatar
dazedandconfused
14mm rotor
 
Posts: 6018
Joined: Thu Apr 05, 2007 6:25 pm
Location: Walton, Kentucky
Top

Re: '92 D150 starting problem

Postby matthewh » Fri Oct 28, 2016 4:53 pm

Probably, I just assumed it was a typo, or a swapped truck.
'93 W350 5spd Getrag, 4.10 gears, 83k miles and counting, Mods: LPPP AKA Ma Dually
'54 Dodge M37 6.2/700R4/205, 5.89 gears, WC rear axle
matthewh
14mm rotor
 
Posts: 619
Joined: Mon Feb 18, 2013 3:07 am
Location: Boyne City Michigan
Top


Return to 1st Gen.org News

Who is online

Users browsing this forum: No registered users and 1 guest

cron